Site doesn't work with url encoded parameters

The site can be used via REST api urls, unfortunately some programming tools/languages automatically urlencode certain characters. This means that this(for example):

This is ‘should’ be perfectly legal in a url but this site doesn’t handle it and we just get an error:
500 - Internal Server Error: undefined method `apply_not+blocked_filter’ for …

See the w3schools page on url encoding.

Hi Neil,

Thanks for the feedback, and I agree - we shall look to make that change.

Can I confirm if you are using the API or modifying the site URL?

Kind regards,

It’s using the API.
The problem actually was the person that raised the issue with me should not have been using the + sign, they should have just used a space, ie: status=not blocked
Then the software would have converted that to a plus sign and it works.
If you manually do the + sign yourself then the software assume you actually want a + sign so it url encodes it.
The moral and recommendation I have is the API should avoid having options that require a ‘space’ in the option so this problem will be avoided.